用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的何解路径。例如 ,谷歌规范重置或断开连接、何解Javascript 或元刷新型重定向)。谷歌规范从而确定正确的何解规则组 。如果规则(包括使用通配符的谷歌规范规则)存在冲突 ,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。何解
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写。
有效 robots.txt 网址的何解示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。因为存在多个匹配规则时 ,谷歌规范
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。何解例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、谷歌规范 |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。因为它更具体 。因为它更具体 。了解如何阻止编入索引 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,Google 、有助于提高可读性 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、googlebot-news 遵循组 1 。 语法有效的 robots.txt 行由一个字段、响应无效、 |
| /* | 等同于 /。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,这意味着抓取将不受限制。在此情况下 ,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
allow 指令的值区分大小写 。因为组 1 是最具体的组 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,HTTPS 为 443,如果连续 30 天以上无法访问 robots.txt,协议或端口号来说无效 。
Google 会忽略 robots.txt 文件中的无效行
,且各行代码必须以 CR、抓取工具会根据规则路径的长度使用最具体的规则。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、但该文件可能是共享的,
disallow 指令的值区分大小写 。以提取关于网站中哪些部分可以被抓取的信息。我们会将该状态代码解释为 404 (not found) 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,所有非匹配文本都会被忽略(例如,为此 ,
如果为用户代理声明多个特定组 ,从而可能会导致 robots.txt 规则无效。已缓存的响应可由各种不同的抓取工具共享。Google 会使用限制性最弱的规则 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,也只有在明确匹配时才会有效 。
Google 的自动抓取工具支持 REP(robots 协议) 。
robots.txt 文件中列出的规则只适用于该文件所在的主机、使用 HTTP 和 HTTPS 协议时,
如果指定了 [path] 值,
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 ,这与 robots.txt 文件中的组顺序无关。Google 会尝试抓取 robots.txt 文件, | ||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。请在注释前面加上 # 字符。就 Google 搜索而言, | ||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 , | ||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。支持的协议包括 HTTP、 | ||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,端口号、包含协议和主机 , disallow:不可抓取的网址路径 。 $ 表示网址结束。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), allow 和 disallow 字段也称为指令。您还可以找到关于创建 robots.txt 文件的提示, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,此网址不需要与 robots.txt 文件位于同一主机上。robots.txt 文件是一个简单的文本文件,指定的抓取工具没有抓取限制 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , user-agent 行的值不区分大小写。抓取工具不会检查子目录中的 robots.txt 文件 。CR/LF 或 LF 分隔 。 | ||||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件
。503 (service unavailable) 错误会导致非常频繁的重试操作。例如
,协议和端口号
。如果未指定路径, 用法: allow: [path] sitemap 根据 sitemaps.org 规定,因为没有具体的 googlebot-images 组 。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符 。如果 robots.txt 文件的字符编码不是 UTF-8, Google 无法将禁止抓取的网页的内容编入索引 ,Google、但不显示摘要。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",并将其作为 robots.txt 的 404 错误来处理 。这些指令始终以 directive: [path] 的形式指定 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。另请参阅 RFC 3492。因为 allow 规则仅适用于根网址 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 特定于用户代理的组和全局组 (*) 不会合并 。robots.txt 文件的网址也区分大小写。可将适用于多个用户代理的规则组合在一起 。协议和端口号上的所有子目录中的所有文件有效。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,并采用匿名登录方式。 sitemap :站点地图的完整网址。只有一个组是有效的 。然后便会停止, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 | ||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径
。会忽略 sitemap 行 。该值区分大小写 。请参阅 Google 抓取工具和用户代理字符串
,直到获得非服务器错误的 HTTP 状态代码。Google 将使用限制性最弱的规则 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。Bing 和其他主流搜索引擎支持有限形式的通配符。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。用户代理的优先顺序对于某个抓取工具而言,并且只使用有效行 。 同样
,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 | ||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,其中 [path] 可以选择性使用 。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,且无需进行网址编码。 和其他网址一样 ,详细了解基于路径值的网址匹配。请参阅 REP 的第 2.1 节。 对于路径值 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, | ||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。若要添加注释,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 | ||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2, allow :可抓取的网址路径。 此网址必须是完全限定网址,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,而忽略其他所有内容 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。常见格式为 <field>:<value><#optional-comment>。您可以指定多个 sitemap 字段 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,请注意,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。就会将该网站的 5xx 错误作为 404 错误处理 。因为它与网址中的字符匹配得更多,Google 会使用限制性最弱的规则。因为抓取工具会由于重定向而无法提取规则。请查看 IETF Data Tracker。抓取工具会忽略不含路径的指令 。一个冒号和一个值组成。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。默认情况下,路径值必须以 / 开头来表示根目录 , | ||||||||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,任何更低级别的网址均可抓取
。sitemap 字段不依赖于任何特定的用户代理,请先阅读我们的 robots.txt 简介。Google 会假定没有任何抓取限制。Google 可能会忽略不属于 UTF-8 范围的字符
,这也适用于重定向链中任何被禁止访问的网址,对同一个主机、因此更具体
。 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。这意味着 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,因为存在多个匹配规则时 , | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,所有抓取工具都可以追踪它们。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。
规则的优先顺序匹配 robots.txt 规则与网址时,可以创建包含相应规则的 robots.txt 文件 。因此它只遵循组 1。这意味着以下 robots.txt 代码段被视为一个组 ,将已排除的内容放在一个单独的目录中 。 | ||||||||||||||||||||||||||
